ISO 19128 |
|||
| Working Group | |||
| Reference | Status/Date | Name | WG |
|
ISO/PWI 19128 |
Cancelled 2014-09-24 |
Geographic information — Web map server interface | 4 |
|
ISO 19128:2005 |
2005-11-23 | Geographic information — Web map server interface | 4 |
| Scope |
|
This International Standard specifies the behaviour of a service that produces spatially referenced maps dynamically from geographic information. It specifies operations to retrieve a description of the maps offered by a server to retrieve a map, and to query a server about features displayed on a map. This International Standard is applicable to pictorial renderings of maps in a graphical format; it is not applicable to retrieval of actual feature data or coverage data values. |
| Document Normative References: |
|
ISO 8601:2004, Data elements and interchange formats — Information interchange — Representation of dates and times |
|
ISO 19111, Geographic information — Spatial referencing by coordinates |
|
EPSG (February 2003), European Petroleum Survey Group Geodesy Parameters, Lott, R., Ravanas, B., Cain, J., Simonson, G, and Nicolai, R., eds., available at <http://www.epsg.org/> |
|
IETF RFC 2045 (November 1996), Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies, Freed, N. and Borenstein, N., eds., available at <http://www.ietf.org/rfc/rfc2045.txt> |
|
IETF RFC 2396 (August 1998), Uniform Resource Identifiers (URI): Generic Syntax, Berners-Lee, T., Fielding, N., and Masinter, L., eds., available at <http://www.ietf.org/rfc/rfc2396.txt> |
|
IETF RFC 2616 (June 1999), Hypertext Transfer Protocol – HTTP/1.1, Gettys, J., Mogul, J., Frystyk, H., Masinter, L., Leach, P., and Berners-Lee, T., eds., available at <http://www.ietf.org/rfc/rfc2616.txt> |
|
UCUM, Unified Code for Units of Measure, Schadow, G. and McDonald, C.J. (eds.), version 1.5 <http://aurora.regenstrief.org/UCUM/ucum.html> |
|
XML 1.0, Extensible Markup Language (XML) 1.0, World Wide Web Consortium Recommendation, Bray, T., Paoli, J., Sperberg-McQueen, C.M., and Maler, E., eds., available at <http://www.w3.org/TR/> |
|
XML Schema, XML Schema Part 1: Structures, World Wide Web Consortium Recommendation, Thompson, H.S., Beech, D., Maloney, M., and Mendelsohn, N., eds., available at <http://www.w3.org/TR/> |
| Referenced from active ISO/TC 211 standard: |
| Model References: |
| Useful Links: |
|
2017 Stockholm Standard in Action presentation - Combining geodata with WMS_Anders Skog |
Supporting the following Sustainable Development Goals:
|
|
|
All projects
- ISO 5974 Evolution and revision formation for Geographic Data Files (GDF)
- ISO 6709 Standard representation of geographic point location by coordinates
- ISO 19101-1 Geographic information — Reference model — Part 1: Fundamentals
- ISO 19101-2 Geographic information — Reference model — Part 2: Imagery
- ISO 19103 Geographic information — Conceptual schema language
- ISO 19104 Geographic information — Terminology
- ISO 19105 Geographic information — Conformance and testing
- ISO 19106 Geographic information — Profiles
- ISO 19107 Geographic information — Spatial schema
- ISO 19108 Geographic information — Temporal schema
- ISO 19109 Geographic information — General feature model and rules for application schema
- ISO 19110 Geographic information — Methodology for feature cataloguing
- ISO 19111 Geographic information — Referencing by coordinates
- ISO 19112 Geographic information — Spatial referencing by geographic identifiers
- ISO 19115-1 Geographic information — Metadata — Part 1: Fundamentals
- ISO 19115-2 Geographic information — Metadata — Part 2: Extensions for acquisition and processing
- ISO 19115-3 Geographic information — Metadata — Part 3: XML schema implementation for fundamental concepts
- ISO 19115-4 Geographic information — Metadata — Part 4: JSON schema implementation of metadata fundamentals
- ISO 19115-5 Geographic information — Metadata — Part 5: DCAT mapping
- ISO 19116 Geographic information — Positioning services
- ISO 19117 Geographic information — Portrayal
- ISO 19118 Geographic information — Encoding
- ISO 19119-1 Geographic information — Services — Part 1: Fundamentals and architectures
- ISO 19121 Geographic information — Imagery and gridded data
- ISO 19123-1 Geographic information — Schema for coverage geometry and functions — Part 1: Fundamentals
- ISO 19123-2 Geographic information — Schema for coverage geometry and functions — Part 2: Coverage implementation schema
- ISO 19123-3 Geographic information — Schema for coverage geometry and functions — Part 3: Processing fundamentals
- ISO 19123-4 Geographic information — Schema for coverage geometry and functions — Part 4: Tiling Schema
- ISO 19124-1 Geographic information — Calibration and validation of remote sensing data and derived products — Part 1: Fundamentals
- ISO 19124-2 Geographic information — Calibration and validation of remote sensing data and derived products — Part 2: SAR
- ISO 19124-3 Geographic information — Calibration and validation of remote sensing data and derived products — Part 3: Optical sensors
- ISO 19124-4 Geographic information — Calibration and validation of remote sensing data and derived products — Part 4: Lidar
- ISO 19124-5 Geographic information — Calibration and validation of remote sensing data and derived products — Part 5: Cross Calibration and Validation for Satellites Constellation and Distributed Sensors project
- ISO 19125-1 Geographic information — Simple feature access — Part 1: Common architecture
- ISO 19126 Geographic information — Feature concept dictionaries and registers
- ISO 19127 Geographic information — Geodetic register
- ISO 19128 Geographic information — Web map server interface
- ISO 19129 Geographic information — Imagery, gridded and coverage data framework
- ISO 19130-1 Geographic information — Imagery sensor models for geopositioning — Part 1: Fundamentals
- ISO 19130-2 Geographic information — Imagery sensor models for geopositioning — Part 2: SAR, InSAR, lidar and sonar
- ISO 19130-3 Geographic information — Imagery sensor models for geopositioning — Part 3: Implementation Schema
- ISO 19131 Geographic information — Data product specifications
- ISO 19132 Geographic information — Location-based services — Reference model
- ISO 19133 Geographic information — Location-based services — Tracking and navigation
- ISO 19134 Geographic information — Location-based services — Multimodal routing and navigation
- ISO 19135 Geographic information — Registration and register governance
- ISO 19136-1 Geographic information — Geography Markup Language (GML) — Part 1: Fundamentals
- ISO 19136-2 Geographic information — Geography Markup Language (GML) — Part 2: Extended schemas and encoding rules
- ISO 19137 Geographic information — Core profile of the spatial schema
- ISO 19139-1 Geographic information — XML schema implementation — Part 1: Encoding rules
- ISO 19141 Geographic information — Schema for moving features
- ISO 19142 Geographic information — Web Feature Service
- ISO 19143 Geographic information — Filter encoding
- ISO 19144-1 Geographic information — Classification systems — Part 1: Classification system structure
- ISO 19144-2 Geographic information — Classification systems — Part 2: Land Cover Meta Language (LCML)
- ISO 19144-3 Geographic information — Classification systems — Part 3: Land Use Meta Language (LUML)
- ISO 19144-4 Geographic information — Classification systems — Part 4: Registration and Implementation Aspects
- ISO 19145 Geographic information — Registry of representations of geographic point location
- ISO 19146 Geographic information — Cross-domain vocabularies